Motor Club Job Offers

Incident Report for Beacon Software

Resolved

This incident has been resolved.
Posted Jun 27, 2023 - 17:29 EDT

Investigating

We are currently investigating an issue with receiving digital job offers from the motor clubs. We are working on resolving the issue and appreciate your patience.
Posted Jun 27, 2023 - 17:06 EDT
This incident affected: TraxeroGO (Motor Club API) and Dispatch Anywhere (Import API).