This incident has been resolved. Thanks again for your patience.
Posted Jun 03, 2025 - 21:30 EDT
Identified
We are still experiencing issues with mobile app users being unable to log in or receive notifications. Microsoft is aware of the issue and is actively working toward a resolution.
Thank you again for your continued patience — we’ll provide another update once the issue is resolved.
Posted Jun 03, 2025 - 15:43 EDT
Investigating
We’re currently encountering issues with accepting job offers, posting invoices, and entering payments. Thank you for your patience as we work to resolve the problem. We’ll share an update as soon as it’s resolved.
Posted Jun 03, 2025 - 08:49 EDT
This incident affected: Dispatch Anywhere (Desktop Client API, Mobile Client API) and TraxeroGO (Client API).