Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 22, 2023 - 07:00 EDT
Scheduled
We will be performing scheduled maintenance on Sunday (10/22/23) at 7:00AM EDT. We are expecting the update to take less than 30 minutes. During this time users may experience outages of the application. An update will be sent out once completed.
Posted Oct 20, 2023 - 17:33 EDT
This scheduled maintenance affected: Dispatch Anywhere (Desktop Client API, Mobile Client API).