Login Issues

Incident Report for Beacon Software

Resolved

Microsoft has resolved the issue, and all applications are now functioning as expected.
We’ll continue to monitor system performance and post any additional updates if needed.

Thank you for your patience and understanding while this was being addressed.
Posted Oct 29, 2025 - 21:24 EDT

Identified

Microsoft has provided an update indicating that they expect full mitigation within the next four hours as recovery of affected nodes continues. Based on this, full service recovery is expected by 23:20 UTC on 29 October 2025.
We will continue to provide updates as progress is made. Thank you for your patience.
Posted Oct 29, 2025 - 16:17 EDT

Update

Microsoft is currently experiencing an outage affecting their Azure platform, which is causing disruptions to related services. The Microsoft engineering team is actively investigating the issue to restore normal operations as quickly as possible.
We are monitoring the situation closely and will provide additional updates as they become available.
Thank you for your patience and understanding.
Posted Oct 29, 2025 - 12:53 EDT

Investigating

We are currently investigating an issue with logging into Dispatch Anywhere on the desktop and mobile apps.
We appreciate your patience as we work to resolve the issue.
Posted Oct 29, 2025 - 11:59 EDT
This incident affected: Dispatch Anywhere (Desktop Client API, Mobile Client API).