This issue has been resolved and emails that were queued are now being processed.
Posted Mar 21, 2023 - 21:07 EDT
Investigating
We're currently experiencing an issue sending emails from Dispatch Anywhere. All the emails are being queued and will be sent after the service is restored. We appreciate your patience and we will send update once resolved.
Posted Mar 21, 2023 - 16:26 EDT
This incident affected: Dispatch Anywhere (Desktop Client API).