Dispatch Anywhere - Creating Invoices/Generating Reports

Incident Report for Beacon Software

Resolved

This issue has been resolved.
Posted Jun 19, 2023 - 18:06 EDT

Investigating

We are currently investigating an issue with creating invoices and generating reports including invoices and statements. Thanks for your patience as we work to resolve the issue.
Posted Jun 19, 2023 - 16:37 EDT
This incident affected: Dispatch Anywhere (Desktop Client API).