Dispatch Anywhere Outage

Incident Report for Beacon Software

Resolved

This issue has been resolved.
Posted May 24, 2023 - 12:52 EDT

Investigating

We are currently investigating an issue logging into Dispatch Anywhere on the desktop and mobile apps.
We appreciate your patience as we work to resolve the issue.
Posted May 24, 2023 - 12:36 EDT
This incident affected: Dispatch Anywhere (Desktop Client API, Mobile Client API).